Nash Central Middle School has lost power - All Internet & Phones are currently down.
Incident Report for NCPS Network Notification
Resolved
Power is now back up and all services (Internet and Phones) have been restored.
Posted Feb 08, 2024 - 13:26 EST
Update
We are continuing to investigate this issue.
Posted Feb 08, 2024 - 13:24 EST
Investigating
We are currently investigating reports of power outage at Nash Central Middle School. Our maintenance department is in contact with Duke Energy and we will provide updates once we are notified of any changes.
Posted Feb 08, 2024 - 12:00 EST
This incident affected: NCPS Network (School - WAN) and Phone Systems - 3CX.