Rapid Identity Slowness Reported
Incident Report for NCPS Network Notification
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 14:25 EDT
Investigating
Message from NCDPI - Identity Automation has reported a performance degradation for the NCEdCloud IAM Service. While NCEdCloud is online and functional, it responds very slowly for users across the state. Identity Automation is working urgently to resolve this issue. We will update you here as more information becomes available.
Posted Sep 16, 2022 - 10:44 EDT
This incident affected: Instructional (Canvas, PowerSchool Products PowerSchool SIS).