Reported power outage Winstead ES

Incident Report for NCPS Network Notification

Resolved

Power restored, Internet and phones are fully operational.
Posted Mar 28, 2025 - 15:47 EDT

Identified

The issue has been identified and power is in the process of being restored.
Posted Mar 28, 2025 - 15:35 EDT

Investigating

We are currently investigating reports of a power outage at Winstead Elementary School.
We will notify everyone once updates are received.
Posted Mar 28, 2025 - 15:25 EDT
This incident affected: NCPS Network (Internet Connection, School - WAN) and Phone Systems - 3CX.