Google email slow and unresponsive
Incident Report for NCPS Network Notification
Resolved
Some Gmail users experienced a delay in sending emails globally for a duration of 4 hours and 45 minutes. Any emails that were delayed after entering our system were auto retried and should have been delivered within a couple of hours after mitigation. From preliminary analysis, the root cause of the issue appears to be an overload in Google Message Router (GMR). Google will complete a full incident report in the following days that will provide a detailed root cause.
Posted Dec 01, 2023 - 13:56 EST
Investigating
Mitigation work is currently underway by Google engineering team.
They do not have an ETA for mitigation at this point.
They will provide more information by Thursday, 2023-11-30 11:15 US/Pacific.
Customers impacted by this issue may see delay for a few mins while sending the emails.
Workaround: Customers can retry sending the email.
Posted Nov 30, 2023 - 13:44 EST
This incident affected: Google Workspace (Google Apps Gmail).