Light Speed Content Filter
Incident Report for NCPS Network Notification
Resolved
Service disruption with one of Light Speed Systems 3rd party providers cause a severe impact on their server and quality of service was reduce. The problem was correct and they will be performing upgrade on their systems this weekend alleviate the slow Internet Speeds we were experiencing.

We appreciate your patience as they worked to resolve this matter.
Posted Sep 29, 2022 - 13:56 EDT
Identified
Service disruption has been identified with one of their 3rd party providers that is impacting Lightspeed Classroom Management and Lightspeed Filter customers.

We are continuing working towards a resolution with them and appreciate your patience in this matter.
Posted Sep 28, 2022 - 14:34 EDT
Investigating
We are experiencing slow response times from LightSpeed when going to websites and have report this.
Certain websites may show blocked or unresponsive when they are allowed.
We will continue to monitor this closely with LS and will advise everyone as information is received.
Posted Sep 28, 2022 - 13:38 EDT
This incident affected: NCPS Network (Internet Connection).