School Power Outage
Incident Report for NCPS Network Notification
Resolved
Power has been restored at Parker MS & Baskerville ES and Internet / Phones are fully operational
Posted Apr 11, 2024 - 17:52 EDT
Investigating
We are currently investing power outages and Parker MS & Baskerville ES.
Posted Apr 11, 2024 - 16:27 EDT
This incident affected: NCPS Network (Internet Connection, School - WAN) and Phone Systems - 3CX.