Canvas login issues
Incident Report for NCPS Network Notification
Resolved
The issues were with Rapid Identity connections and they have been resolved.
Posted Oct 25, 2022 - 13:01 EDT
Investigating
We are aware of Canvas login issues that are occurring here and across the district. DPI is investigating.
Posted Oct 25, 2022 - 10:39 EDT
This incident affected: Instructional (Canvas).